i3d lässt sich nicht öffnen

Moderator: Moderatoren



AbonnentenAbonnenten: 0
LesezeichenLesezeichen: 0
Zugriffe: 306
Beitrag 14. Apr 2016, 00:39
FippoJo Benutzeravatar
User

Servus zusammen!


Ich hab mir heute den (endlich richtigen :D ) Case Optum besorgt.
Wollte ihn ein wenig überarbeiten, der glänzt ja wie ein speckiges Schwein...

Mein Problem:
Weder die i3d des 270er, noch des 300er lassen sich im GE öffnen.
Hatte ursprünglich die Version 6.0.3 drauf, daraufhin die aktuellste 6.0.5 versucht, ebenfalls nichts.

Als Fehler meldet der GE "Parse error at [...] in line 1. not well-formed (invalid token)".

Also gut, mal die i3d im Notepad++ geöffnet und die erste Zeile unter die Lupe genommen... Sieht dann so aus:

Bild


Klar, dieser Sprache ist der GE wohl nicht mächtig. :cry:

Sobald ich die erste Zeile in der i3d durch eine korrekte aus einem anderen Mod ersetze, meckert der GE über die zweite Zeile. Von daher liegt es wohl an der Verschlüsselung, oder wie auch immer man das nennen mag.

Ingame funktioniert der Mod bis auf zwei fehlende l10n Einträge fehlerfrei.

Was mir noch auffiel: Die Zip ließ sich nur über die Repairfunktion entpacken, vermute das ist Absicht.

Hat jemand eine Lösung? Brauche ich einen bestimmten Editor, oder ein PlugIn?

Bin für jede Hilfe Dankbar.


Gruß,
FippoJo

Beitrag 14. Apr 2016, 14:55
Scholli Benutzeravatar
V.I.P

Beiträge: 21
Wohnort: 79688 Dreiländereck D-CH-F
Geschlecht: männlich

Hallo

Ich habe in den Kommis zu dem Mod folgendes gefunden:


"Das Zip-Archiv einfach mit WinRAR reparieren, dann lässt es sich entpacken. Die i3d versteckt sich in den dds im Root-Verzeichnis. Die xml liegt als wav im Sound-Ordner * zwinker, zwinker* "

Fiel mir schon beim Durchschauen auf, bist du dir sicher, dass du die "richtige" i3d in Arbeit hast?

Habe den Mod noch nicht geöffnet, könnte ja aber eine Fake i3d sein.

Gruß...
...vom Scholli

Manchmal sind die Bösen die besseren Guten!

Beitrag 15. Apr 2016, 09:14
FippoJo Benutzeravatar
User

Scholli hat geschrieben:
Hallo

Ich habe in den Kommis zu dem Mod folgendes gefunden:


"Das Zip-Archiv einfach mit WinRAR reparieren, dann lässt es sich entpacken. Die i3d versteckt sich in den dds im Root-Verzeichnis. Die xml liegt als wav im Sound-Ordner * zwinker, zwinker* "

Fiel mir schon beim Durchschauen auf, bist du dir sicher, dass du die "richtige" i3d in Arbeit hast?

Habe den Mod noch nicht geöffnet, könnte ja aber eine Fake i3d sein.

Gruß...


Servus!

Vielen Dank für diese aufschlussreichen Infos.

Hab mir das Ganze mit diesem neuen Hintergrundwissen nochmal genauer betrachtet.

Im Sound-Ordner sind tatsächlich zwei als .wav getarnte Fahrzeug-XMLs. Allerdings unterscheiden sich diese allem Anschein nach in nur einer Sache von den beiden vermeintlich falschen XMLs aus dem Hauptorder:

In den versteckten wird die i3d unter
<filenames> </filenames> zugeordnet.

In denen aus dem Hauptordner unter
<filename> </filename>

Ich kenne diesen Eintrag bisher nur in der Einzahl, weshalb ich unsicher bin, welche Variante korrekt ist.
Ich vermute aber, dass beide Varianten funktionieren; die XMLs im Hauptordner werden lediglich nicht abgerufen, was wohl die Umstände für Veränderungen am Mod erschweren soll.

Sehe ich das richtig?

Die beiden versteckten i3ds habe ich auch gefunden. Liegen in der Tat im .dds Format im Hauptordner und lassen sich mit dem GE öffnen.
Was mich hier allerdings noch verwirrt, ist die Tatsache, dass sowohl in den versteckten, als auch in den sichtbaren XMLs unter </filename(s)> die falschen i3ds eingetragen sind, sprich
"caseIHOptum [...] .i3d" und nicht
"caseIHOptum [...] .dds".

Trotzdem läuft der Mod...

Wenn ich die .dds im GE öffne und als .i3d speichere, bleiben diese sehr klein; weit unter 1 MB. Normalerweise sollte die doch weitaus größer sein, oder?

Kann es sein, dass die i3ds irgendwie kombiniert geladen werden?

Das macht mich total Banane..! :roll:


Gruß,
FippoJo


Zurück zu "Archiv Supportbeiträge"


Wer ist online?
Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast